Articles of apt

试图升级的nginx依赖问题

尝试升级我的Ubuntu 12.04 vps我收到以下错误: henrik@neung:~$ sudo apt-get upgrade [sudo] password for henrik: Reading package lists… Done Building dependency tree Reading state information… Done You might want to run ‘apt-get -f install’ to correct these. The following packages have unmet dependencies: nginx-full : Depends: nginx-common (= 1.2.4-1ubuntu0ppa2~precise) but 1.2.4-2ubuntu0ppa1~precise is installed E: Unmet dependencies. Try using -f. […]

如何使用TOR SOCKS代理apt-get?

我在我的Ubuntu 14.04中运行浏览器,并且在成功连接后我在我的浏览器中使用了socks :127:0.0.1:9150并且它工作正常。 但是当我把Acquire :: socks :: proxy“socks://127.0.0.1:9150 /”时; 在apt.conf中,它根本不起作用。 我怎样才能在袜子上使用apt-get? 请帮我。 谢谢。

更新时Ubuntu 15.04 Linux 4.0 Python错误,子进程/ usr / bin / dpkg返回错误代码(1)

在运行autoremove命令或更新时,甚至对于任何安装命令,我都会遇到以下错误。 我的系统是Ubuntu 15.04从14.04升级,Linux内核从3.19升级到4.00。 我已经安装了python 3.4.3并且我可以通过python命令使用python3。 请帮助我完全处于糟糕的状态。 TIA vivek@Wisdom:~$ sudo apt-get autoremove Reading package lists… Done Building dependency tree Reading state information… Done The following packages will be REMOVED: linux-image-3.19.0-16-generic linux-image-extra-3.19.0-16-generic 0 upgraded, 0 newly installed, 2 to remove and 55 not upgraded. 13 not fully installed or removed. Need to get 0 B/89.4 kB of […]

dpkg opporations失败:无法运行depmod,error handlinglinux-image-generic

我的笔记本电脑最近几次失去了电量,现在,每当我尝试进行打包操作时,我都会收到以下错误代码。 我尝试在论坛上搜索解决方案,但这些要么需要打包操作,要么没有得到答复。 ‘uname -r’告诉我我的内核是3.11.0-17-generic,但似乎我的内核头文件说3.11.0-18-generic。 我尝试启动旧内核版本以尝试解决问题,但我遇到了同样的错误。 谁知道我能做什么? sudo apt-get install -f Reading package lists… Done Building dependency tree Reading state information… Done 0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded. 4 not fully installed or removed. After this operation, 0 B of additional disk space will be used. Setting up linux-image-3.11.0-18-generic (3.11.0-18.32) […]

总线错误(核心转储)

请急需帮助……我无法安装或更新任何东西,我的系统只是打印出来 总线错误(核心转储) 我不记得在错误开始之前做任何奇怪的事情,请帮忙。

卸载Plasma桌面

我正在使用ubuntu 16.04 LTS并使用以下命令安装了等离子桌面: sudo apt-get install plasma-desktop 但后来我使用这些命令卸载它: sudo apt-get purge plasma-desktop sudo apt-get autoremove 重新启动系统后,登录屏幕仍然可以选择Ubuntu(默认)或Plasma。 我想彻底清除血浆。

使用代理时,’apt-get update’失败

使用apt-get update我得到了 错误http://ppa.launchpad.net精确/主要amd64包 404未找到 W:无法获取 http://ppa.launchpad.net/webupd8team/jupiter/ubuntu/dists/precise/main/binary-amd64/Packages 404未找到 E:某些索引文件无法下载。 他们被忽视或者老了 用的而是。 机器在代理后面,代理正确配置,并且从互联网上获取的其他软件包不会出现错误。 ppas更常见。 从来没有遇到其他来源的问题。 有问题: deb http://_ppa.launchpad.net/rabbitvcs/ppa/ubuntu精确主要 deb [arch = amd64] http:__ ppa.launchpad.net/webupd8team/jupiter/ubuntu exact main 也试过使用Acquire :: http {No-Cache = True;}; 和treid清理列表的缓存sudo rm / var / lib / apt / lists / * 什么都没有成功。 失败的url在浏览器中或使用wget完美打开。 只有在使用代理时才会出现此问题。

如何在Ubuntu 14.04中创建自定义ErrorDocument页面?

我是Ubuntu的新手,我使用的是Ubuntu Server 14.04。 现在我想使用我自己设计的HTML网页作为我的服务器状态错误,如404等。我尝试了自己的方式,但没有得到我的设计页面,当我打开192.168.1.99/404时,我得到服务器默认错误页面文件不在我的var/www/ ,如下所示。 我的var/www/文件夹中有index.html , 404.html , .htaccess文件。 我的.htaccess文件仅包含ErrorDocument 404 /404.html行。 我没有更改任何默认设置。 我只是安装Ubuntu Server 14.04并通过终端使用它。 你能告诉我现在该做什么吗?

无法安装PHP CURL,php5-常见的差异

每当我尝试安装php5-curl , php5-common , php5我总会得到以下错误: The following packages have unmet dependencies: php5-curl : Depends: php5-common (= 5.3.10-1ubuntu3) but 5.3.10-1ubuntu3.7 is to be installed E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).` 我已经尝试了所有建议,包括清理,删除,更新。 我无法重新安装或启动新实例。 有什么建议? System information as of Tue Sep 3 04:50:44 UTC 2013 System load: 0.0 Processes: 72 […]

12.04上的未满足依赖性问题 – libcurl4-openssl-dev取决于librtmp-dev

我在Ubuntu 12.04上遇到了未满足的依赖问题: libcurl4-openssl-dev取决于librtmp-dev 这是我在运行sudo apt-get -f install之后sudo apt-get -f install ,它建议运行apt-get autoremove 如果我运行sudo apt-get install librtmp-dev ,输出是相同的 Reading package lists… Done Building dependency tree Reading state information… Done Correcting dependencies… Done The following packages were automatically installed and are no longer required: libmagick++4 libgtkspell0 libgsl0ldbl Use ‘apt-get autoremove’ to remove them. The following extra packages […]