Articles of 包管理

安装linux-image-4.10.0-33-generic时出现磁盘完全错误

我是ubuntu社区的新手。 我在使用17.04时遇到了问题:即使在运行了大多数推荐的脚本之后,我仍然无法解决以下错误。 我能做什么? linux-signed-image-4.10.0-33-generic : Depends: linux-image-4.10.0-33-generic (= 4.10.0-33.37) but it is not going to be installed E: Unmet dependencies. Try ‘apt –fix-broken install’ with no packages (or specify a solution). dingi3@dingi3-HP-Pavilion-15-Notebook-PC:~$ sudo apt –fix-broken install Reading package lists… Done Building dependency tree Reading state information… Done Correcting dependencies… Done The following additional packages will […]

更新后MPlayer无法正常工作

在12.04中使用update-manager进行更新后,MPlayer不再工作了。 它需要ffmpeg ,但由于未满足的依赖性而无法安装。 我为ffmpeg添加了PPA,但没有解决问题。 见输出: Python (v2.7) requires to install …. GStreamer ffmpeg video plugin. Codecs to play mpeg, divx, mpeg4, ac3, wmv and asf files. 使用安装,我收到一条错误消息,由于未满足的依赖性,它无法安装。 见下面的列表: The following packages have unmet dependencies: gstreamer0.10-ffmpeg: Depends: libavcodec-extra-53 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed Depends: libavformat-extra-53 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed […]

从3d-party存储库安装包

我需要从非ppa存储库安装包。 所以,通常的sudo apt-add-repository… & apt-get update并不令人担忧。 当然,我可以从这里手动下载所有必需的软件包,但我必须手动安装这些软件包并解决依赖关系。 所以,这不是解决我的问题。 如何安装此3d-party应用程序? 有趣的是,该存储库的结构重复了archievev.ubuntu.com存储库的结构。

在Ubuntu 16.10上安装Trelby时出错

我正在尝试在我的Ubuntu 16.10上安装Trelby,但是我收到了Python的依赖错误。 我如何通过此错误?

如何降级smbclient

我正在尝试降级smbclient,因为不再使用backuppc。 我已按照本文中的说明如何降级Ubuntu上的软件包? 但它似乎没有用。 我跑了 sudo apt-cache showpkg smbclient sudo apt-get install smbclient=2:4.1.6+dfsg-1ubuntu2 但这没有任何作用。 smbclient版本仍然是版本4.3.9-Ubuntu。 我试过清除smbclient然后重新安装。 这导致未满足的依赖性。 vagrant@vagrant-ubuntu-trusty-64:~$ sudo apt-get install smbclient=2:4.1.6+dfsg-1ubuntu2 Reading package lists… Done Building dependency tree Reading state information… Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable […]

修复冲突的依赖关系

目前在带有i5 660的Dell Optiplex上运行Ubuntu 16.04 我遇到的问题看起来像依赖冲突,但我不确定我是否正确解释输出。 有人可以帮我理解我在看什么并帮我修复它吗? sudo apt-get upgrade Reading package lists… Done Building dependency tree Reading state information… Done You might want to run ‘apt-get -f install’ to correct these. The following packages have unmet dependencies: libwinpr-heap0.1 : Depends: libc6 (= .= 2.2.5) but 2.23-0ubuntu5 is installed E: Unmet dependencies. Try using -f. humberto@DellServer:~$ […]

处于不确定状态的系统 – 我应该拥有的包的综合列表是什么?

我用包裹搞砸了。 试图修复Ubuntu 11.10中的X11问题,​​我已经完成了几个包添加和删除,每个都添加了一些依赖项组合。 我不知道我的系统应该是什么,但是当我一直试图解决屏幕截图无法解决的问题,3d问题,我的台式机数量限制,触摸屏问题时,我一直认为这很重要我的系统仍然缺少包,尽管事实上apt-get说一切都很好。 我在哪里可以找到ubuntu 11.10在我的系统上应该安装的内容的完整列表,所以我可以sudo apt-get all darn thing?

Steam不会运行(缺少libGL.so.1)

我正试图在我儿子圣诞节的笔记本电脑上安装Steam(运行Ubuntu 14.04.3 LTS),但是当我第一次尝试运行Steam时(通过它创建的“Steam”桌面图标),终端窗口出现,我被告知: Steam needs to install these additional packages: libgl1-mesa-dri:i386, libgl1-mesa-glx:i386, libc6:i386 输入密码就可以了,然后我被告知: Reading package lists… Done Building dependency tree Reading state information… Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not […]

在存储库之外更新

我们假设,我有一个应用程序(称为abc),即在当前存储库中,版本1.0。 所以我今天在互联网上找到了新闻’BREAKING:abc 1.5版发布,IT修复一切’,每个人都疯了。 当然,我想尝试一下。 如果我下载一个deb文件并立即安装abc 1.5(并假设没有依赖性问题),那么当版本1.5或1.6进入存储库时,这将如何影响我的系统? 我是否仍然可以正常更新存储库,或者那个软件然后以某种方式奇怪地“切出”? 奇怪的问题,我希望有人理解。

安装新库后与未满足的依赖关系相关的问题

从Ubuntu 15.04升级到15.10后,我的Canon PIXMA MX870上的扫描仪出现问题,而Simple Scan或Xsane无法识别。 我找到了关于如何使其工作的答案: 原始问题 建议的解决方案建议在我的Ubuntu 15.10上安装实验库。 它真的解决了我的问题,我可以看到我的扫描仪,但不幸的是TeamViewer 11需要libjpeg62(原始库)。 重新安装TeamViewer后,它“修复”了所需的一些库,但随后我的Simple Scan和Xsane应用程序消失了。 从我的“apt-get autoremove; apt-get autoclean”输出: 以下软件包将被删除:argyll argyll-ref gnome-control-center-data gnome-settings-daemon libcolord-gtk1 libgoa-backend-1.0-1 xsane-common Debian Expirimental – Libs libjpeg62-turbo版本:1:1.4.80-115-gfb907b2-1 libsane-common版本:1.0.26~git20151121-1 libsane版本:1.0.26~git20151121-1 当我尝试安装简单扫描时,出现以下错误: simple-scan:取决于:zlib1g(> = 1:1.1.4)但是要安装1:1.2.8.dfsg-2ubuntu4 尝试安装Xsane时会出现类似的消息: xsane:取决于:xsane-common(= 0.998-6ubuntu1)但是要安装0.998-6ubuntu1 Depends: libc6 (>= 2.14) but 2.21-0ubuntu4.1 is to be installed Depends: libgimp2.0 (>= 2.4.0) but 2.8.14-1ubuntu2 is […]