为什么我们在Win10中启用WSL时需要安装Ubuntu

为什么我们在启用WSL时需要安装ubuntu?

    这取决于您的需求:

    1. WSL中提供的Ubuntu有些过时,它不是最新版本的Ubuntu。 但是,您可以启动docker镜像并提取更新版本或其他版本的Ubuntu或其他版本的Linux。

      • 请参阅https://github.com/RoliSoft/WSL-Distribution-Switcher
    2. WSL没有在Linux内核上运行,因此一些Ubuntu / Linuxfunction不可用。 图形应用程序是混合的,虽然您可以在Windows上运行X服务器,但我不相信您可以运行Wayland。

    3. 除内核应用程序外,并非Ubuntu存储库中可用的所有程序都将在WSL中运行。

    因此,如果WSL完成了您需要的一切,并且您没有开发Wayland应用程序,那么它可能正常工作。

    另一方面,某些用户和/或开发人员需要的function在WSL中不可用,在这种情况下,您必须安装Ubuntu / Linux。

    在这个答案中,很难不能列出每个人的需求或WSL的所有限制,但是有关其他信息,请参阅:

    请参阅Windows子系统Linux的限制是什么? 有一些限制。

    有关WSL限制的概述,另请参阅https://docs.microsoft.com/en-us/windows/wsl/faq 。

    有关持续存在的错误和缺失的function,请参阅https://github.com/Microsoft/WSL/issues/ 。