如何在具有可卸载依赖项的情况下安装32位库?

我正在尝试在Ubuntu 13.10上安装Adobe Air。 在这个版本的Ubuntu中,像ia32-libsia32-libs-multiarch这样的软件包不再可用,所以我正在尝试自己安装所需的32位库。 在运行./AdobeAIRInstaller.bin我遇到了一些关于缺少库的错误,其中大部分我使用sudo apt-get install :i386并且错误消失了。 我在修复最后两个丢失的模块时遇到了问题:

  Gtk-Message:无法加载模块“overlay-scrollbar”
 Gtk-Message:无法加载模块“unity-gtk-module” 

我尝试使用apt安装overlay-scrollbar-gtk2:i386

  overlay-scrollbar-gtk2:i386:取决于:overlay-scrollbar:i386但它不可安装 

嗯,这取决于无法安装的包。 多么不方便。 所以我尝试使用Googling前往Saucy的32位覆盖滚动条库, 我在这里找到了 。 首先我安装了overlay-scrollbar:

  $ sudo dpkg -i overlay-scrollbar_0.2.16 + r359 + 13.10.20130826-0ubuntu1_all.deb 
 (正在读取数据库... 226507当前安装的文件和目录。)
准备替换overlay-scrollbar 0.2.16 + r359 + 13.10.20130826-0ubuntu1(使用overlay-scrollbar_0.2.16 + r359 + 13.10.20130826-0ubuntu1_all.deb)...
打开更换覆盖滚动条的包装......
设置overlay-scrollbar(0.2.16 + r359 + 13.10.20130826-0ubuntu1)...
处理libglib2.0-0的触发器:i386 ...
处理libglib2.0-0的触发器:amd64 ... 

大! 有效。 然后我尝试安装overlay-scrollbar-gtk2:i386:

  $ sudo dpkg -i overlay-scrollbar-gtk2_0.2.16 + r359 + 13.10.20130826-0ubuntu1_i386.deb 
选择以前未选择的包覆盖 -  scrollbar-gtk2:i386。
 (正在读取数据库... 226507当前安装的文件和目录。)
解包overlay-scrollbar-gtk2:i386(来自overlay-scrollbar-gtk2_0.2.16 + r359 + 13.10.20130826-0ubuntu1_i386.deb)...
 dpkg:依赖性问题会阻止overlay-scrollbar-gtk2:i386的配置:
  overlay-scrollbar-gtk2:i386依赖于overlay-scrollbar。

 dpkg:error handlingoverlay-scrollbar-gtk2:i386(--install):
 依赖性问题 - 保持未配置状态
处理时遇到错误:
 叠加滚动条GTK2:I386 

显然我仍然需要安装overlay-scrollbar:i386,它不能由apt安装,也没有安装上面的安装程序。 我对unity-gtk-module的问题几乎完全相同,但包名不同。

关于此,我有几个非常相关的问题:

  • 为什么一些非常重要的32位软件包无法使用apt安装? 我错过了一个来源吗?
  • 为什么上面没有安装i386版本的overlay-scrollbar? 是因为安装程序包含32位和64位版本的库,并自动决定只在我的系统上安装64位版本? 我可以强制它同时安装吗?

     apt-get download overlay-scrollbar-gtk2 sudo dpkg --ignore-depends overlay-scrollbar -i overlay-scrollbar-gtk2*.deb 

    简单。

    如果您已经为您的架构安装了软件包,那么这将有效。 如果没有,您将在下次尝试使用dpkg / apt-get时遇到错误。 要修复它们,请运行:

     sudo gedit /var/lib/dpkg/status 

    查找Package: [package name, overlay-scrollbar-gtk2 in this case] ,并从Depends:删除被忽略的依赖项Depends:在这种情况下为overlay-scrollbar)。

    如果您使用gedit,请确保在保存之前在编辑>首选项>编辑器中禁用了自动备份 。 请注意,gedit对每个用户都有单独的首选项,并且您以root用户身份运行它。

    overlay-scrollbar包没有i386或amd64风格; 它是一种“全”的味道,安装在所有的拱门上。

    它似乎缺少Multi-Arch:allowed标头,因此根据它不会满足i386包。 您应该提交错误报告,询问是否添加了缺少的标题。